Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
A
adapter_pkgs
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package registry
Container registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
David Tiede
adapter_pkgs
Commits
a6ef8f6f
Commit
a6ef8f6f
authored
4 years ago
by
David Tiede
Browse files
Options
Downloads
Patches
Plain Diff
CMakeLists.txt installs
parent
c9247de8
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
safety_planning_request_adapters/CMakeLists.txt
+34
-10
34 additions, 10 deletions
safety_planning_request_adapters/CMakeLists.txt
with
34 additions
and
10 deletions
safety_planning_request_adapters/CMakeLists.txt
+
34
−
10
View file @
a6ef8f6f
...
...
@@ -14,15 +14,39 @@ catkin_package(
include_directories
(
${
catkin_INCLUDE_DIRS
}
)
# plugin
add_library
(
${
PROJECT_NAME
}
src/add_safety.cpp
)
target_link_libraries
(
${
PROJECT_NAME
}
${
catkin_LIBRARIES
}
)
install
(
TARGETS
${
PROJECT_NAME
}
LIBRARY DESTINATION
${
CATKIN_PACKAGE_LIB_DESTINATION
}
)
install
(
DIRECTORY include/
${
PROJECT_NAME
}
/
DESTINATION
${
CATKIN_PACKAGE_INCLUDE_DESTINATION
}
)
set_target_properties
(
${
PROJECT_NAME
}
PROPERTIES VERSION
"
${${
PROJECT_NAME
}
_VERSION
}
"
)
target_link_libraries
(
${
PROJECT_NAME
}
${
catkin_LIBRARIES
}
${
Boost_LIBRARIES
}
)
#############
## Install ##
#############
# Mark executables and/or libraries for installation
install
(
TARGETS
${
PROJECT_NAME
}
ARCHIVE DESTINATION
${
CATKIN_PACKAGE_LIB_DESTINATION
}
LIBRARY DESTINATION
${
CATKIN_PACKAGE_LIB_DESTINATION
}
RUNTIME DESTINATION
${
CATKIN_GLOBAL_BIN_DESTINATION
}
)
install
(
FILES planning_request_adapters_plugin_description.xml
DESTINATION
${
CATKIN_PACKAGE_SHARE_DESTINATION
}
)
\ No newline at end of file
# Mark cpp header files for installation
#install(
# DIRECTORY
# src
# DESTINATION
# ${CATKIN_PACKAGE_INCLUDE_DESTINATION}
#)
#catkin_lint ignore uninstalled_plugin
install
(
FILES
planning_request_adapters_plugin_description.xml
DESTINATION
${
CATKIN_PACKAGE_SHARE_DESTINATION
}
)
\ No newline at end of file
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment