Commit b8c40f79 authored by Johannes Mey's avatar Johannes Mey
Browse files

set cmake C++ version to 14 (requirement of Gazebo headers)

parent b6859e94
cmake_minimum_required(VERSION 2.8.3)
project(gazebo_grasp_plugin)
set(CMAKE_CXX_STANDARD 14)
## Find catkin macros and libraries
## if COMPONENTS list like find_package(catkin REQUIRED COMPONENTS xyz)
## is used, also find other catkin packages
......
cmake_minimum_required(VERSION 2.8.3)
project(gazebo_state_plugins)
set(CMAKE_CXX_STANDARD 14)
## Find catkin macros and libraries
## if COMPONENTS list like find_package(catkin REQUIRED COMPONENTS xyz)
## is used, also find other catkin packages
......
......@@ -3,6 +3,7 @@ project(gazebo_version_helpers)
## Compile as C++11, supported in ROS Kinetic and newer
# add_compile_options(-std=c++11)
set(CMAKE_CXX_STANDARD 14)
## Find catkin macros and libraries
## if COMPONENTS list like find_package(catkin REQUIRED COMPONENTS xyz)
......
cmake_minimum_required(VERSION 2.8.3)
project(gazebo_world_plugin_loader)
set(CMAKE_CXX_STANDARD 14)
## Find catkin macros and libraries
## if COMPONENTS list like find_package(catkin REQUIRED COMPONENTS xyz)
## is used, also find other catkin packages
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment